RSS
Facebook
G+

Buscador de IntercambioSOS:


Retroceder   Foro de Ayuda IntercambiosvirtualeS > Soporte Sobre: Software > Sistemas Operativos

Respuesta
 
Herramientas Desplegado
Antiguo 05-feb-2018     #1
Predeterminado Windows 10 y Ubuntu compartiendo disco de datos (Solucionado)

Me instalé un disco duro sólo para datos y lo particioné como partición extendida formato NTFS, mi intención era que lo compartieran amigablemente Windows 10 y Ubuntu 16.04.

Sin embargo, cuando trabajé en el disco desde Windows 10, se crearon varias particiones primarias nuevas y Linux ya no fue capaz de montar el disco duro.

He encontrado una solución sencilla: cuando termino de trabajar con Windows, deshabilito el disco:

Tecla Windows+X -->Administrador de Dispositivos -->Unidades de disco-->(Seleccionar disco)--> (Botón derecho)-->Deshabilitar dispositivo

Cuando tengo que utilizar el disco de datos desde Windows de nuevo, hago los mismos pasos y Habilito el dispositivo.

Espero que a alguien le ayude ;)
Responder Citando
Los siguientes 4 usuarios agradecen a rafa-yo por este mensaje:
Florderetama (06-feb-2018), Ghost (05-feb-2018), Orpheus96 (05-feb-2018), Sandra0001 (05-feb-2018)
Antiguo 05-feb-2018     #2
Predeterminado

Hola Rafa-yo,

Utilizar tu disco de datos desde ambos sistemas operativos es perfectamente posible desde que (ya hace mucho tiempo) Linux es capaz de manejar las particiones NTFS sin problemas.

Pero Windows 10 ha introducido una "mejora" que impide precisamente eso.

Se trata de la mal llamada función de "Inicio rápido", que puedes encontrar entre las opciones de gestión de energía, bajo el punto "Definir los botones de Inicio/Apagado".

Tienes que localizar la opción de "Activar Inicio rápido" y desmarcar esa opción.

Con esta opción desactivada, ya podrás montar las particiones en tu Linux en arranque dual sin ningún problema.


Explicación:
Lo que hace realmente esa opción de "Inicio rápido" es que al apagar el equipo, congela el estado de la tablas de asignación del disco en memoria y la "hiberna". Se supone que cuando se vuelve a iniciar Windows, en lugar de cargar esa tabla de asignación desde el disco, la recupera desde esa memoria de hibernación (¡que también se guarda en el disco!).

Pero claro, al apagar los discos sin actualizar sus tablas de asignación, los discos quedan en un estado "erróneo", muy parecido a cuando se apaga el equipo por corte de corriente y que requiere un "scandisk" para recuperar o corregir dicha tabla de asignación.

Linux, cuando encuentra una partición NTFS en estado "erróneo" no la monta automáticamente a fin de evitar daños a esa partición. De hecho, se puede forzar el montaje a pesar de ese error; pero no suele ser una buena idea a menos que sepamos lo que estamos haciendo.

Así que todo se reduce a ordenar a Windows que apague correctamente los discos, de modo que puedan ser utilizados por otro SO.

De hecho, la mejora de rendimiento que promete ese "Inicio rápido" nunca la he notado y, en cambio, provoca bastantes problemas de integridad en los discos. Sobre todo cuando cacharreamos más de lo habitual con nuestros equipos.

Fíjate que lo que estás haciendo al "desactivar" el disco es precísamente forzar a Windows a guardar en disco su tabla de asignación y desmontarlo correctamente. Pero tener que hacerlo manualmente resulta muy molesto.


Perdona el latazo. Espero haberte ayudado.
Salu2

Última edición por Sandra0001; 05-feb-2018 a las 12:41
Responder Citando
Los siguientes 4 usuarios agradecen a Sandra0001 por este mensaje:
Florderetama (06-feb-2018), mikeangel21 (07-feb-2018), Orpheus96 (05-feb-2018), rafa-yo (05-feb-2018)
Antiguo 05-feb-2018     #3
Predeterminado

Muchas gracias Sandra. Estuve mucho rato intentando lo que dices, pero las pantallas que me encuentro en Google son diferentes a las que yo tengo, me fue muy frustante y no fui capaz. Por otro lado comprobé que el comportamiento del botón de apagado está configurado como "Apagar"

Incluso lo intenté desde la línea de comandos con POWERCFG y me da mensaje de error:


C:\Users\Rafa>powercfg /h off
No se puede realizar la operación. Se produjo un error inesperado (0x65b): Error de una función durante la ejecución.


De momento la única manera que me ha funcionado es la explico más arriba, la he puesto por si le sirve a alguien
Responder Citando
Los siguientes 4 usuarios agradecen a rafa-yo por este mensaje:
Florderetama (06-feb-2018), mikeangel21 (07-feb-2018), Orpheus96 (05-feb-2018), Sandra0001 (05-feb-2018)
Antiguo 05-feb-2018     #4
Predeterminado

Hola Rafa-yo,

Te indico las pantallas donde se encuentra esa opción.

Desde "Configuración - Sistema - Configuración adicional de energía" accedes a "Opciones de energía":



En esta pantalla, en el menú lateral de la izquierda, pulsas en "Elegir el comportamiento del botón de inicio/apagado". Te llevará a esta segunda pantalla:



Y en la parte de abajo, en la sección de "Configuración de apagado" encontrarás la opción de activar o desactivar el "Inicio rápido".

Para poder cambiar estas opciones, antes debes pulsar en la frase superior que dice: "Cambiar la configuración actualmente no disponible".
Está muy mal explicado. Lo que quiere decir es que para cambiar estos valores, antes debes darle permiso de administrador haciendo clic en esa línea.

Una vez hecho, ya puedes desmarcar la opción que te decía y guardar los cambios.

Espero que puedas encontrarlo. Puede que en las diferentes "Builds" de Windows 10 estas opciones hayan cambiado un poquito; pero debería ser muy parecido a lo que te copio.

Suerte...!
Responder Citando
Los siguientes 5 usuarios agradecen a Sandra0001 por este mensaje:
Florderetama (06-feb-2018), matigari (07-feb-2018), mikeangel21 (07-feb-2018), Orpheus96 (05-feb-2018), rafa-yo (06-feb-2018)
Antiguo 06-feb-2018     #5
Predeterminado

Sandra0001


Responder Citando
Los siguientes 2 usuarios agradecen a Florderetama por este mensaje:
mikeangel21 (07-feb-2018), Sandra0001 (06-feb-2018)
Antiguo 06-feb-2018     #6
Predeterminado

Ahora sí Sandra ! Muaks!
Responder Citando
Los siguientes 3 usuarios agradecen a rafa-yo por este mensaje:
Florderetama (06-feb-2018), mikeangel21 (07-feb-2018), Sandra0001 (06-feb-2018)
Antiguo 06-feb-2018     #7
Predeterminado

Me alegro de que lo hayas conseguido.

A mi me pasó en su momento algo muy parecido, al cambiar entre distintos sistemas, y era un verdadero fastidio. Hasta que encontré la causa y pude resolverlo.

Enhorabuena y gracias por tu interés.
Salu2
Responder Citando
Los siguientes 5 usuarios agradecen a Sandra0001 por este mensaje:
Florderetama (06-feb-2018), matigari (07-feb-2018), mikeangel21 (07-feb-2018), rafa-yo (27-feb-2018), Rolly16 (09-feb-2018)
Respuesta


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Descarga Windows 7, 8.1 y 10 utilizando un código javascript (Actualizado) tortex Windows Vista & 7 28 31-may-2017 11:11
¿Se te dañó la PC y no sabes cómo repararla? Entra pirelin PC's Desktops 0 25-dic-2013 00:22
Historia de Windows y otras cosas de Microsoft jamespoetrodriguez Sistemas Operativos 26 24-nov-2012 05:56
Que Ocurre en el Administrador de Tareas cejd Tutoriales & Videos Tutoriales 6 11-may-2012 23:25
Optimización para Windows XP - Tips Windows XP by Arleanjose AgUiLa32 Tutoriales & Videos Tutoriales 26 14-sep-2010 20:48


Desarrollado por: vBulletin® Versión 3.8.1
Derechos de Autor ©2000 - 2018, Jelsoft Enterprises Ltd.
Ad Management by RedTyger